Skip to content


PHP-5.3.0 в Debian Lenny.

Многие задаются вопросом, как установить PHP-5.3.0 в Debian Lenny.

Официальные пакеты есть только в experimental. Сборка из исходников тоже не метод — debian не source-base дистрибутив.

Однако, появилась сборка PHP-5.3.0 для Debian в репозитариях dotdeb.

Для установки добавим в /etc/apt/sources.lst:

deb http://php53.dotdeb.org stable all
deb-src http://php53.dotdeb.org stable all

И выполним apt-get update; apt-get upgrade.

Если apt-get выдаст нечто вроде:

The following packages have been kept back:
libapache2-mod-php5 php5 php5-common php5-gd php5-mcrypt php5-mysql

Значит, ваша система считает репозитории DotDeb  «untrusted source».

Путей исправить это два:

  1. Найти PGP-ключ DotDeb и установить в систему в качестве trusted.
  2. Устанавливать через apitutde или с ключем —force.

Не найдя ключа я выбрал второй. Установка прошла успешно, проблема возникла только одна под PHP5.3.0 —  пока нет модуля php5-memcached. Но это дело наживное. :)

Posted in Без рубрики.

Tagged with , , , .


One Response

Stay in touch with the conversation, subscribe to the RSS feed for comments on this post.

  1. differentlocal says

    Use Google, Luke!
    В чем именно проблема?



Some HTML is OK

or, reply to this post via trackback.